$tu(rndimg, ... doesn't work

The formula doesn’t work. Root → Background → Image (bitmap, formula)
Have also tried to create object Img and use the same formula - the same result.
Have tried to use the main storage instead of SD card.
It’s obviously wrong path to the folder, but I have tried all possible combinations. Plz, help
$tu(rndimg, 15, “/storage/9C33-6BBD/Download/Wallpapers”)$
Have also tried
$tu(rndimg, 15, “/9C33-6BBD/Download/Wallpapers”)$
$tu(rndimg, 15, “9C33-6BBD/Download/Wallpapers”)$
$tu(rndimg, 15, “/sdcard/Download/Wallpapers”)$

This could be an access issue. Try moving your images inside your main Kustom folder. You can also check if Flows will work for you. You can use the information from the link below as a guide.

try “/storage/emulated/0/Download/Wallpapers”

This is a duplicate of this:

Closing

It lloks like duplicate, but actually it’s another question : why it doesn’t show a picture if the path to it correctly defined? See attached. And the the img is regularly updated (every 15 minutes) as shown on the screenshot.

As @frank mentioned in your other post, this is due to a change in Android’s storage access policy. You can either move your images inside your main Kustom folder or use Flows.

As y can see on the screenshot the files are already inside the Kustom folder. It located on SD card, but anyway the path and file can be seen by the app. But the img is not viewable in the gadget.

Did you try what I wrote in post #3? It works for me.

Yes. I have tried it. I copied files to the main storige as the path in your example. But it didn’t work and obviously couldn’t work … What version of Android do you have?

Thanks Frank and Ace for the answer and link to tutor. Now it works nearly as I wanted.
Generally I dont understand what for to keep the functions that don’t work in the repository. It’s just confusing…

I’m on 14, but it worked on 13 as well.

Doesn’t work. I have moved Kustom folder (Settings → General → Main storage) to the main storage, placed images in the Kustom folder. It shows correct path (see screenshots) but the image not loaded into widgets.
$tu(rndimg, 15, “/storage/emulated/0/Apps/Kustom/Wallpapers”)$
Have tried on different devices


You are right that function should be hidden since now it doesn’t work on most of the devices however it should work for Kustom folder when you use “/sdcard/Kustom/file” as a path. Kustom will automatically replace /sdcard/ with the document access and it will allow you to access files inside Kustom folder, just use /sdcard/ there.