Si(mindex) in Global not Populating in Global assigned text

I’m trying to use si(mindex) in a Global (for use with a weather resource). I’ve just noticed that if I assign this global to a resource it doesn’t work (returns 0 always) BUT if I use that same Global inside a formula, it works as expected.

Steps to reproduce:

  1. Create a Global with si(mindex)
  2. Create an Stack Group (easier to test with)
  3. In the Stack Group, create a Text item and set the Text to the Global you created in #1
  4. Copy that Text item a few times

To verify the global works as expected, instead of setting the Text item to a Global in Step 3, add the Global variable in the Formula of the Text item and copy it a few times.

@frank I’ve not seen any bug reports about this but I presume this is not intended? Not sure why you’d have to use a formula rather than just being able to assign the Global directly?

Oh, something to note that I’ve just spotted - when I go to apply the Global to the Text item, it’s not showing the full path to the Global. which is likely the reason…

I have the global inside 2 folders (weather/forecase/temp) - when I go to assign it it only shows as weather/temp but when I assign it inside the Formula, it sets it with the full path.

Can you reproduce the issue with a Global variable that’s not inside a folder?

No, because from what I can see it’s something to do with the fact that the variable is 2 folders deep.

One way to prove that theory is to actually test this without using a folder.

OK sorry, you’re spot on!! Even at the root of the Globals it still doesn’t work as expected.

To test I created the following structure:

Stack Group
> Stack Group
   > Text Item (x10) - Text value set to Global
> Stack Group
   > Text Item (x10) - Text value with $gv(testvar)$ in Formula

Global was testvar with the Formula $si(mindex)$

The child with the global in the Formula worked as expected, the other showed up with 14 in every text item.