Problems with Fitness data

Hi. I’m trying to make a fitness widget on KLWP that tracks your steps, distance traveled, and calories burnt but for some reason the calories tracking remains at 0 while the other stats work fine. I used $fd(cals)$ to display the calories spent. Here are the screenshots of the data that is in Google Fit, and what is displayed on my widget.

I have tried:

  1. Reinstalling both the Google Fit and KLWP app.
  2. Granted KLWP unoptimized battery usage mode.
  3. Tried the same widget with the same formulas on KWGT.

So far they have failed to solve the problem. Does anyone have the same issues that I’m having, or knows a fix that I can work with? It would be very much appreciated. Thanks for reading and have a nice day.

Google Fitness integration is unfortunately deprecated, i will migrate to health connect in 3.75, please be patient, you can track the status in this thread

1 Like

Thanks for the update!

Oh. That’s a good news.
Looking forward to the update in the future.

This topic was automatically closed 25 days after the last reply. New replies are no longer allowed.