Notifications not recognized

I’m trying to make a notification dot on my watchface.
I’ve tried to read the state of notifications with these formulas:


But all of them reports a 0 when on my watch.
I can still see my notification on my watch being present if I toggle between tiles but kwch won’t see it.
I’ve checked my permissions and kwch has all permissions it’s asking for.
The watch is a galaxy watch 6 classic running WearOS 4 (OneUI 5).

I have the same issue (and the same watch)

1 Like

I suggest you try using Complications instead. I don’t think notification data is being synced from your phone to the watch. Complications will pull notifications directly from the watch.

I’ve tried using your advice and used complication data but doesn’t do anything (previous reply was wrong, hence why I deleted it).

I’ve tried using these formulas to see what values I can use:

$cd(8, stext)$ $cd(8, rval)$ $cd(8, rmin)$

But all of the always return a 0. With or without a notification I always get a 0.
I’ve made sure to set data 8 on my watch to “notifications”.

Am I doing this wrong, with the formulas I’ve used I should at least get something if a notification is present or not, right?

Take note that the notificaiton that you’re going to get here are notifications in your watch and not your phone.

I sent myself a text message, it popped up as a notification (notification sent from phone to watch) and that doesn’t count as a notification according to the complication?

That’s a bummer, I’d love to have a little notification dot appearing for any notification but seems that isn’t possible. Oh well, I can’t complain, it’s such a small thing and I can live without it. Thank you for explaining!

1 Like

I tried this Kode & my notification shows within the editor for KWCH but the notification text never displays on my watch face with Kwear.

$if (cd(1,ltext),(ni(, text)))$

This Kode (which I also use in KLCK) will also display my notification text in the KWCH editor but never on the watch face itself:
$if(ni(, text)>0, ni(, text))$

The notification of course appears on my watch via the Google Messages app.

I’m using KWCH ver. 3.75b408115 (032124)
KWEAR ver. 0.01b408115 (032124)

Edit2: I’ve tried selecting “Notifications” for the 1 slot in complications. I tried app shortcut and selected “Messages” but nothing works (I didn’t think this would work for displaying text but just opening the app).