Music Information not updating after latest beta

After the latest beta update, music information variables (mi(len), mi(pos)) are not getting updated. Version 3.75b407209.

I tried normal things (killing cache, restarting, rebooting) but not working.

Thanks for the continued development.

Can you check if this is only affecting Spotify? Spotify seems to be having some issues in their recent release.

Upon further investigation it seems like the issue is limited to media played by Podcast Addict. Another music player (GoneMAD) works fine.

I have the “Preferred Music Player” set to Automatic. There is no option to set it to Podcast Addict (somehow I think that a choice for Podcast Addict may have existed in the past and is now not there - but I am not 100% sure)

Within Podcast Addict I have also set a “Broadcast Played Content” to on (in wasn’t previously set to on - and it had still worked) - but that does not make any difference.

Basically, I am not getting any Music Information for media played on Podcast Addict.

Any ideas and help would be appreciated.

OK - I powered up a phone that I had not used in along time. I confirmed that:

  • For “Preferred Music Player” - Podcast Addict was listed (along with some others that no longer appear).
  • $mi(package)$ - listed the package name of Podcast Addict. That is not being listed in the current beta.

So, it appears that - for some reason - kustom is not seeing Podcast Addict - and perhaps other media players.

I have similar issue with Audio Book Player “Sirin”. Its not listed in Media Player and info wont be fetched by KWGT. Even Tasker wont identify it as media player.

I also have the same issue with Samsung Watch 6 music player.
The watch face doesn’t react in any way. No title, no duration and no way to skip to next/previous song.
I checked that mi(package) is empty during music playing with Samsung music player as also with WearMedia Music Player.
Finally I tested the Music Player Komponent that not works too.
Substantially all that $mi()$ are useless.
Just another question.
The only thing that works are the “mi” that raise or lower the volume but if I configure a touch with that the result is that on Galaxy Watch 6 the volume interface is shown so if I want to lower/raise volume a bit I’ve to wait each press that the volume interface disappears or I have to use the volume interface.
Is it possible to have volume ± buttons that works as expected?

I can see “Podcast Addict” listed as a preferred music player both on the latest beta and the play store version. Can you make sure that you have the latest version of Podcast Addict installed?

Audio book player apps may not be compliant with Android music player standards which is what the Kustom app is looking for.

I am actually on the latest beta of Podcast Addict as well. Version 2024.6d (build 21133)

I may not have mentioned it, but I am on LineageOS version 21 (Android 14) - if that is relevant. I am on the latest nightly build from today (3/18/24).

Actually, this may be an issue in the latest beta. I’ve already informed Frank about this.

Fixed in latest beta (3.75b408115)

This topic was automatically closed 25 days after the last reply. New replies are no longer allowed.