KWCH error DF-DFERH-01 with v3.75

Loving the KWCH app by the way. once it is out of beta i wil buy it.

i am getting this error DF-DFERH-01 when i want to send a KWCH watch design to my galaxy watch 4 updated to latest wear os. in combination with galaxy s20FE android 13 ui 5.1

i tried resetting the watch multiple times. force-closing the google playstore. clearing the playstore cache and data. uninstalling all playstore updates. Both on the watch and on phone side. restarting both devices. This fixed it for someone else on this forum with the same DF-DFERH-01 error. but did not help for me.

also uninstalled the watch KWCH and installed it again. also on the phone side. did it with all possible combinations. and at least 10 times on both sides of the devices. but nothing works.

I still keep getting this error when tryng to send any watch design to the watch. it tells me the watch needs to have the KWCH installed(it already is installed on the watch) and then error message.

Also a weird behaviour. Both the phone and the watch have KWCH installed but the watch tells me that the phone needs to have the app installed. and the phone tells me the watch needs to have the KWCH installed. it is like they dont have the same version or they dont communicate.

The version 3.74 did work. so either i am unlucky or there is some deeper issue.
Just letting you know. i dont expect a solution soon as you can not repeat this issue. i know how this works. i am a programmer too. It takes time.

Maybe someone has the same issue. then that is a start to a solution.

Check the setup process from the link below and see if that helps. If not, I suggest you send an email to [email protected] so they can investigate on this further.

Thanks for the suggestion.

Tried this variation on installing it. But still the same result, same error.
in time i will contact [email protected]

Hello @Par
First off, if you can go into your watch face selection area and can actually get to the KWEAR app, make sure that you allow permissions. Otherwise–>

If you want to try re-installing KWEAR try side-loading/installing the KWEAR app using this app is great. I’ve side-loaded KWEAR from the beginning with great success. You’ll need to enable Developer options on your watch.
Good youtube videos are around as well as discussion posts.

I’ve also noticed this issue on a Pixel 7 Pro with a Mobvoi TicWatch 3 Pro.

I’ve got this same issue on a fossil gen 6 and pixel 8 pro. Tried factory resetting the watch as well as fresh installs of the apps on both phone and watch. All permissions granted on both devices as well

Edit: I side loaded 3.74b331712 on the phone and 0.01b331712 on the watch and got them taking again

Sorry this is a 3.75 issue, working on it

This is now fixed in version 3.75b404014beta

The version is “in review” on play store, might take a few days

Manual download is available but install needs to be done on both the wear OS device AND the watch unfortunately.

Downloads as usual are here:


The newest version let me connect again.

1 Like