Klck not working after Android 10 update

Just got the update for Android 10 on my OP 6T and once loaded I had to do some setup to get klwp and kwgt to work properly. However, klck won't apply, everything is good in the editor, "set as lock screen" is on and display over other apps is on but I still get system lock screen. Also, oddly, klck isn't on Google play store anymore. It's not listed under KHI apps, not in my "my apps" section and not under past downloads. Klck pro key is there but not klck. If I go to the installed app settings in my phone and click on app info, which takes you to it's play store page, it says app not found, retry

Same problem I have with a Mate 20 Pro, KLWP & KWGT both work fine after updating to Android 10 but KLCK won't stay active, it will sometimes show straight after leaving the editor but mostly it won't. The thing is, I've tried a few other lock screen apps and they work fine so it's not an issue with the phone, I'm currently using C-Locker for now, but hoping KLCK will be fixed.

Klck would randomly work for me as well, maybe twice a day I would see it but I had issues with other apps as well. System and third-party apps would constantly force close. I ended up rolling back to Android 9 and everything works perfect again

Same issue, updated to Android 10 on the OnePlus 6 and KLCK will no longer work. :(

Same on Samsung Note9 and Q

Just an update, so I finally got a response from the devs and they basically said there is no way to replace the system lock screen per Google's guideline, which is why KLCK will always be in bet and it has to be something to do with Android security in Q update. Knowing how many people use Kustom apps on their phones, not to mention the selling point of being customizable and having open source licensing for devs, I don't see why Google would put something in place to stop that

Thanks for the info, but this doesn't explain why C-Locker & others still function on Android 10.

I also use an app called App-Cloner, I cloned KLCK with that app and added an accessibility service to keep KLCK alive and it worked. The only issue is that I cannot use the paid features with the clone.

So that could be a workaround but I feel the devs have given up.

Agreed. It also doesn't explain why I can roll back to pie and everything works fine again. Was hoping it was just an issue with the initial "stable" 10 release so went back to pie for a few months and decided to try 10.3.2 yesterday but same problem. It seems something is killing the app, I set a certain portion of the screen to lock the phone on single tap and also added the touch function to launch klck on touch, so when I tap that spot, it locks the phone but also launches klck. This will display klck over system lock screen about half the time, but annoyingly, always unlocks straight into adv editor

Best workaround I've found so far is using macrodroid (and Nova launcher). I created a macro and set the trigger to empty trigger, set action to launch app Kustom lock, wait 3 seconds, launch shortcut Nova action screen lock. You can set the action in macrodroid to lock screen but with the type of accessibility macro uses to lock, you can only unlock with primary security setting, ie facial and fingerprint are disabled, Nova accessibility is the same but you can switch that setting to lock screen as if power button were pressed which still allows you to use facial and fingerprint to unlock. Then set touch on a KLWP komponant to launch shortcut macrodroid (name). I'm using an invisible rectangle directly above my dock icons and on touch will launch klck, and lock phone 3 seconds later. The only drawback is waiting those 3 seconds before putting the phone in my pocket just in case. You can set the wait time to milliseconds if you'd like but it usually takes 2 - 3 seconds to actually launch and load preset, I haven't tested if it will work properly if the screen locks while the app is still loading preset. This will show klck upon screen turn on 100% of the time and it does not unlock phone directly into advanced editor. I wish klck would work as intended but this will do for now

Same issue for me on Galaxy Note 10+ (OneUI 2.1/ Android 10)!
I recently found another workaround on this Reddit forum post. Works perfectly! I'm still using Nova Launcher and now the Automate app.

This Post has links within to use with Automate. A Big Thanks to Reddit User U/mmakes

There have been some updates the last weeks, now KLCK works for me on Android 10 and 11 (LineageOS 17 and 18) - hope this is a general solution for all Android versions.