How do I unlink my Google account from KWGT

While trying to figure out the fitness data fix, I linked my Google account in Settings-Advanced Options in an effort to sync the fitness data. Now my email address appears in the author field every time I want to export a preset. This is not ideal, I would much rather be able to unlink my Google account at any time. Is this possible in KWGT?

1 Like

This post from Frank might help:

Hello Ace,
Thank you for responding. I should clarify that I do not want Google Fit to be disconnected, I was referring to the section of KWGT settings under Advanced Options/Settings where you can login with Gmail account. After doing so, the email address shows up permanently when exporting presets. Does that clear things up?



1 Like

I’ve also been wondering this, I would prefer to not show my real name here as standard when exporting as well as use another e-mail from my standard e-mail if possible.

I understand. As far as I know, there’s no way within the app to do that. You can just clear KWGT’s app data instead.

Login will be required at some point for some feature, i need to create a way to override login information when exporting or in general in the setup. If you want to logout right now you should be able to do so by pressing in the settings your username, if there is no logout option then its a bug

1 Like

Go to your Google dashboard and unlink it there.

1 Like

@win7guru / @Cindanela This is fixed in next version (3.75), app will ask you to logout when clicking the logged in user in the advanced settings. I will also be removing the username/email readonly field when logged in on the export dialog unless preset export is readonly.

1 Like

Thank you @frank
I appreciate you fixing it/enhancing it. This will help a lot, because I had to uninstall and lose all of my homescreen widgets after reinstalling KWGT, seemed like a bug. Anyway, sorry for the late reply. Have a great week.

If you haven’t exported you can always find your widgets in the backup tab

Can you provide a screenshot, I do not see the backups tab