Entering "-" alone causes crash in cron in flows

I have searched for this issue using searchbar but it doesn’t seems anyone found it yet. Sorry if this has been solved in beta version as i use the release version. This issue is seems to be in cron component in flows, i have tested in klwp and kwgt both apps have it. Possibly it could be also in klck but i have never used it.
in Flows → Triggers → cron → Cron string enter “-” before 0 and then remove zero and automatic cron string format checker that is checking the format will cause crash that i believe so maybe add exception to the format checker to symbol “-” (-) it’s dash or negative symbol that crashes app entirely. I checked for other symbols but it only seems this one symbol causes this issue. Thank you. Also tried to add tag klwp but it forum doesn’t let me add the tag so please add way to add multiple tag such especially in some cases as reporting in issues category. Thanks :blush:

I’m able to reproduce this. Seems like placing a “-” symbol alone in any of the 5 elements crashes the app.

I know that we are not supposed to use “-” in cron format but it causes crash causing unsaved data to lost, that’s why I thought it would be better to report to add exception to that symbol in format.

Thanks for reporting, this has been fixed in next version 3.76

This topic was automatically closed 25 days after the last reply. New replies are no longer allowed.