Different issues with KWGT AOSP version


Using KWGT version 3.74b322206aosp currently.
I was using version 3.73 but I had to try betas hoping they will solve the issues I’ve been having recently.

When I try to add a widget, it would open normally, but after 15 - 20 seconds, KWGT force closes.
When it’s open a toast message shows up constantly, “Consent update error”
After 2 or 3 reboots, the widgets don’t show up anymore, they stay in “Loading…” state.
After a few widgets have been added, eventually KWGT will refuse to open any other, an error would show up with a message like this one “Error: Failed to determine if primary:Kustom/widgetsShortcuts_3.kwgt is child of primary: Kustom: Java.io.File…”

I rely a lot on KWGT for my normal day to day use of my devices, so I would really like to find a solution to these issues.

I’ve tried different beta versions on 2 devices, a Pixel 7 running crDroid A13 and a Galaxy Tab A8 running Lineage 20 GSI A13. Both devices are rooted with Magisk and running with Nova Launcher.

I don’t see many people complaining about the same issues as me, so I must be doing something wrong.

Any help would be appreciated.

1 Like

Working on this issue, sorry for it. This is specific to AOSP, please be aware that if you were running Play Store version just use that instead. If you are intentionally using AOSP then please wait for next update.

1 Like

Hello, I have the same problem. Using CRDroid too. I already sent several messages and logcat, but still waiting for a solution :roll_eyes:

Issue is fixed now, please download latest AOSP build from Downloads | Kustom HQ

1 Like

It seems to work again, but advertisements are appearing even when using Pro

There is no “pro” in the AOSP version, Kustom paid version is available only on Huawei and Google stores.

Today it stopped working.

AOSP version has not yet fixed the problem.

So I really wasted money buying the pro version…:frowning:

No solution yet

If you purchased PRO you can always ask for a refund at [email protected] unless you purchased from Huawei. That said, whats the issue with AOSP? Why are you using AOSP if you have Google Play?

I just found out about the AOSP version. Will test it. But so far, every time I open KWGT, I get a repeated message “Consent update error”.
I had the latest 3.74 version installed and the Pro Key prior with no widgets.

I’m using AOSP because I have a custom ROM and the Google Play version didn’t work.

I used the Pro version for a long time and it always worked, but after a few months it stopped and the message keeps appearing. I already sent a log to support but they never got back to me.

I will try to refund :melting_face:

Unfortunately the same problem with the newest AOSP version. After a few reboots, the widgets will not load anymore, the widget spaces stay in “loading…”

Dam i got the same error

Same here!
Playstore version and pro key

CRdroid 9.10 (problems noticed since 9.7) Android 13
Magisk 26.3 rooted, nikgapps core.
All KWGT Versions available on kustom site v3.57 to v3.74.

Difference is in v3.57 my widget is loading but after a while doesn’t recognize the weather icon (not there) and my fonts so they use the standard android font. Any other version has the same problem as OP mentioned.

Btw: Looks like there is a slash (/) missing in the error message it’s the same here! "primary:Kustom/widgets(/)MyWidget.kwgt "

ps: AOSP != no playstore

thanks for reading

This topic was automatically closed 25 days after the last reply. New replies are no longer allowed.