Clock Delay

Hi, I’m using KLWP 3.74b with Honor Magic 6 Pro (Android 14) with the default widget (cpu and clock) Issue: The clock has big delay - others work in real time like CPU…
Any idea how to fix?

Go to the Clock Overlap Group >> Layer. Make sure that Location and TZone are properly set. Also, go to KLWP’s app settings >> Location - make sure that everything is properly set here as well.

Is anything else in the wallpaper updating? If not please ensure KLWP is removed from battery optimization, if service is gone then it won’t update