Calendar events update fail if I don't open Google Calendar.

I am using third party calendar (business calendar 2) with Google calendar sync (Google calendar installed).

I find the following

1) Input new events in third party calendar (business calendar)

- events shown correctly in third party calendar

- events shown correctly in the widget of Google calendar

- events shown correctly in chrome (web view of Google calendar)

- events shown correctly in klwp editor

- events not update in klwp (updated in editor)

*** everything goes fine after I open the app "Google Calendar"

2) Input events in Google calendar

- Events shown correctly in everywhere.....

could you help me?

thank you so much

having exactly the same issue. Have you found and solution for this?

I was using Tasker/Automate to force re-sync “com.android.calendar”, it solved the problem…

eg:
stage 1) when on home page
stage 2) force re-sync “com.android.calendar”
stage 3) stop for 30s
stage 4) return to “stage 1”

Loop

or you can do it manually,
setting > accounts > select your google calendar account > account sync > turn off “calnedar” then turn on

I am not sure whether it works now…

Is it necessary to use SecureTask plugin in Tasker to force re-sync? And I was assuming that syncing and refreshing are 2 different things (refreshing the android google calendar app manualy works for me but I want to have it autmated as it should be)

I disabled the sync in Calendar and hit refresh manually in the calendar app and the events showed in the klwp wallpaper right away so it is a matter of ‘refresh’ option and not ‘sync’

i do not use tasker anymore. tasker is hard to use for me.
and i forget how to set it up…sorry

i am using automate

autmoate
just add the block called “Account sync request”
Account name = your google account
account type = com.google
data authority = com.android.caledner

i think there are many way to solve this issue, just use the easiest and most convenient methods.

-----updated----
after google

I also installed “synker” with tasker but this app is no longer available in goolge play

Thank’s for inspiration:) seems to be working by toggling Taskers net - auto-sync option on and off. I created a task that runs that after adding an event and seems to be working now. Funny how you need to manipulate those apps to work as you seem fit