Widget not clickable on MIUI 10.2.14

So I can drag a widget onto my homescreen, but I cannot click it at all. It just says "click to setup...". I can't click on an already existing widget either.

So far I've tried:

-reinstalling KWGT and the pro key multiple times, different orders etc

- restarting my phone

-changing launcher

-resetting phone

But none of these helped. This problem has occured for 1 Week now, and I am using a Xiaomi Mi 9


I resolved this problem by following these steps:

  • Place a widget
  • Long press on the widget and choose 'App info'
  • Select 'Other permissions'
  • Select 'Start in background' and change to 'Accept'

Hope this works for you too!

It actually did. Why didn't I think of this! Thank you very much :)

Yes, I had got the same issue on MIUI 11 on MI8 and I solved it with this indication

Hi everyone. That's happened to me too (Mi9, MIUI10, pro kwgt, nova prime).
My assumption is that after few restarts - not related to the problem - something went bad and all my apps' permissions (i.e. location, calendar, contacts etc.) together with the Autostart feature and other permissions (e.g. "display pop-up windows while running in the background" etc.) were set to disabled/ blocked.
Now, I had to grant back these permissions manually... (including storage for KWGT in order to find the related icons).
I hope there will be an update of MIUI10. Meanwhile, if someone understand how this is happening please feel free to share with us in order to avoid another wipe of permissions...

i do anything above but nothing works. so i put clock widget from stock android because i can load any widget to homescreen (nothing happened when i click widget area)

Miui11 - Nova Prime

(but in miui launcher i can add any widget from klwp)