Unable to change photo with tasker variable

Hi, I’ve been using kwgt and tasker to comand my smart home devices, the icons go from gray to colors if they are inactive or active.


Since the last update it doesn’t work anymore on my Pixel 6, but still working on my old tablet with android 9.
If I use a formula like this one

$if(br(tasker, SHELLYGARAGEISON) = false, “/storage/emulated/0/Pictures/widget/Garage OFF.png” , “/storage/emulated/0/Pictures/widget/Garage ON.png”)$

The image is not visible. If I use the same formula on a text like this

$if(br(tasker, SHELLYGARAGEISON) = false, “[c=#FF565656]Pwr[/c]” , “[c=#FFFF9200]Pwr[/c]”)$

The text go from gray to orange.

I thought that it was some memory permission problem introduced in the new beta (I’ve read this topic No storage permissions - #5 by N_Valo) but even installing an older version it doesn’t work anymore!


You can try re-importing the preset. If the issue persists, you can do a clean install using the steps from the link below. Make sure that you have everything exported and backed up before you proceed.

I’ve tried re-importing and a clean install but still not picking up the image

I’m having a similar issue. I made my own taskbar with icons based on tasker variables, as well as an automated wallpaper switcher and both stopped working for me today. Galaxy S21 FE on Android 13 here. 5.1 OneUI still.

I’ve found the solution! I had to put all the images on the Kustom folder and then change the formula path like this:

$if(br(tasker, SHELLYGARAGEISON) = false, “file:///Kustom//Garage OFF.png” , “"file:///Kustom/widget/Garage ON.png”)$

Kustom has no access to the storage anymore

Kudos! This is the way (cit) OR you can use flows, by triggering a flow via formula and then setting an image as a global, this would work on any folder although might be a bit more complex

I thought it might be the storage permission issue, so I put my files in the Kustom folder and that didn’t work. I hadn’t tried changing the path from “storage/emulated…” to “file:///Kustom//…”. I’ll give it a try! Thank you.

This topic was automatically closed 25 days after the last reply. New replies are no longer allowed.