Theme, Image, and Fonticon Loading Issues

I have not been able to figure out a solution to the issues I have been having since about mid May. I am on android 13 with a OnePlus 7 Pro running YAAP. There have been some mentions of issues with apps like KLWP, KWGT, and Amazon music, but the YAAP devs seem to believe it is an issue with those apps and not the ROM, which I would believe mainly because the issues started randomly and not after an update. That may be incorrect though, but I wanted to see if anyone here could help.

My main issue is that images and fonticons will randomly stop loading in the theme on the homescreen, or they will not show up when attempting to load an exported theme. Sometimes the theme will also freeze and have issues with touch input . Additionally, I have had various issues loading exported themes.

For the images, they will either completely disappear, or they will instead be the default image icon. Changing the image to a different one does nothing. However, album art images work perfectly fine and show up normally.

Fonticons turn into the question mark icon that indicates that no icon was found. When attempting to change the fonticons in the theme, usually instead of saying the Fonticon group is “Entypo”, for example, it will say “iconsentypo” and when opening the menu to change the icon, every group of them will have a name like that and all the icons are just the x in a box icon as if an emoji was unavailable, and they are not selectable.

When the issue originally occurred, I was using app version 3.55 from the website. I had no issues with the theme, and when editing it previously everything was normal. Randomly, the images on my home screen theme started to disappear, only a couple at first but eventually everything was gone, and the fonticons also broke. All touch input and everything else was perfectly fine, just the images and fonticons. I went into the app to try to reapply the theme, and despite the thumbnail looking perfectly fine, once it loaded in, all of the images and fonticons were broken.

After this happened, I started to have issues with loading my exported themes. Sometimes they would load incorrectly, but they would still load, but other times they would give an “Error: Attempt to invoke virtual method 'boolean org.kustom.lib.render.RenderModule.update(org.kustom.lib.N)…” error. I could get around this by applying the most recent theme from settings instead of hitting save after loading the theme, but it would still be broken. On certain versions though, such as 3.74, doing that changes nothing.

Themes from app packs generally loaded perfectly fine, unless I tried to load one of my custom exported ones first. If I did that, I would have to reinstall the app or else it would give the same error on every theme, although sometimes it would be fixed after a restart, but not consistently. Also, while the images and fonticons from those themes would load perfectly at the start, eventually they would break the same way.

Also, seemingly randomly the theme will either just not scroll, but other touch input works, or completely freeze and not work with any touch input. It seems to be related to the render.RenderModule.update issue as that issue appears when loading the theme right after the freezing happens.

After this started happening, I went through many troubleshooting steps.

I first tried the latest version of the app, which was 3.73, which did nothing to fix the issue, instead it just resulted in the theme loading infinitely after applying sometimes. I have tried practically every app version, including 3.74 now, and none of them fixed the issue. 3.55 seems to be the most stable one, as it has the fewest issues with applying the theme.

With most of these app versions I completely deleted the kustom folder after making backups, and tried to import the theme after creating a clean folder. However, often it would give an error saying that KLWP could not determine if the file is a child of the kustom folder. Copying the file into the folder directly worked, but did not fix the other issues.

I also tried completely recreating my theme from scratch, which I did twice, each time the image and Fonticon issues happened around halfway through so I stopped. Multiple other themes have had the same issue. The loading issues seem to happen more often with my main one, possibly because it has the most images.

When recreating them I had the theme open on my computer using the windows subsystem for Android, which also had the same image loading issues, but that may just partially be because the version I loaded in had been exported after some of the loading issues occured. I was running version 3.55 there as well.

I tried clean flashing my phone when one of the YAAP updates was released, but it changed nothing. I have not tried going back to oxygenOS or a different rom, as that is an annoying process, but I may try it if there’s no other way.

Sorry that this is kinda long, I just wanted to give as much information about the issues as possible.