When building a complex formula, it would be nice to be able to write custom functions to improve readability. For example, while a formula reacting to rain could be written as
if(wi(icon)="RAIN"|wi(icon)="SHOWER"|..., it would be nicer to create a separate function
is_rainy that could then be used inside the formula, encapsulating the not-so-readable boolean condition.
The current workaround for this is to simply create a global variable which fulfills the same purpose, but this can get very cluttered with many globals.