Step count always 0

I’ve always had KWGT to show the step count from Google Fit as well as the kilometer count, but since some time now it’s always zero for some reason. Any idea on how to fix this?

First, make sure that KWGT has access to Health Connect. Just go to Health Connect settings >> App Permissions - Allow KWGT.

I tried turning that on and made sure Google fit syncs to it as well, but nothing shows up, despite confirming Google fit as synced data to it.

Is there any way to get data from Google fit directly instead of the middle man health connect? Some other apps still access Google fit directly, if that’s the issue.

The app used to pull data from the Fit API. Since Google moved to Health Connect, Kustom also transitioned to Health Connect.

  1. Go to Health Connect settings.
  2. Navigate to Data and Access >> Activity >> Steps.
  3. Ensure that KWGT and Fit are listed.
  4. If they are, select “See all entries” on the same page and verify that the correct step data is shown.

After a lot of tweaking I finally also got a message on activating a permission within the KWGT editor that I didn’t get the last time, then with a bit of wait, the thing got started. What a chore. Thank you!

Oh wow, now that I got it all working I realize kwgt wakes the phone every minute to update step count. What a battery abuse. Why so frequent? Once per hour perhaps, but every minute? Can this be changed?