Step always 0 on the watch

The steps are displayed correctly on the phone in the KWCH App but on the watch the step counter does always show 0.

Using Text $fd(steps)$
Pixel Watch
Google Pixel 7 Pro

I have created a complication and have the steps displayed there, this works.
Samsung Galaxy Watch 6

Using Tasker and AutoWear ?
If yes is there a HowTo available?
For example which Complication to Update?
(e.g. Ranged value 1)
How to add this complication to KWCH App ?
The only way I could Imagine is $cd(, rval)$ ?

Found this on Reddit below but that does not work.

I added the Steps to Slot 1 but I can’t find it in kwch App.
What is the ID? Under ID1 there is calendar…

You can change the content of the complications in the wearable app or on the watch, but in KWCH, the ID does not change.
I think it only synchronises in one direction, from the smartphone (KWCH) to the watch.


$tc(nfmt, mu(round, cd(1, rval)))$

I have a Sumsung Galaxy 5 Pro watch and a Samsung Note 10 phone. Using Samsung Health on the phone i was unable to see the steps. I later installed Google Fit with tracking disabled and installed Heath Sync to synch samsung health data to google fit - i am now able to see the steps.

I can’t seem to show steps also, when I create the progress bar and the step counter the app keeps asking to correct because it has no access to steps and then it asks me to login with Google, when I log in I get a notification saying that Google blocked the app because it was trying to get important information and I just cannot unblock it.

I searched everywhere for this, there was once that option to allow “less secure apps” but Google discontinued that, can someone help me with this?

Install KLWP and grant permission in this App.
Permission will be granted for KWCH also

Also see

Thank you! That worked, got to access Google fit and show it’s steps, but I can’t seem to sinc the watch steps connected to Samsung Health to Google Fit, Google just tries to calculate steps independently even though I connected Google Fit to Samsung Health. Do you know something about this?

Also my previous components that I created prior to the steps seems to have stoped working, the configuration is still the same, checked both on the phone and the watch. When I click the button on the Watchface the watch vibrates as it is receiving the touch, but nothing happens found it very weird.

Sorry for the lack of skills with the app, I’m a complete newbie to this custom creation of watchfaces.

If you’re trying to simply show your step data in KWCH on your watch, use complications instead.

I have noticed that the KWCH app on the watch doesn’t have “Sensors” authorization unlike, for example, WatchMaker.

Is maybe this the reason?


This topic was automatically closed 25 days after the last reply. New replies are no longer allowed.