Starting over from autosave, elements missing?

I have pro versions of KWGT and KLWP. I am a bit of a newb, but have been playing and experimenting in both for quite awhile. I had a calendar widget going, then attempted to adjust the grid of my wallpaper through novalauncher. This made my calendar widget disappear. When I tried to load from autosave, it unfortunately had not saved a lot of my more recent edits. But I me trying to recreate what I had, I notice there are now parts of the element that are missing, but these were not added by me. These were parts of the base calendar widget that I added. It gave different options to use as arrows to advance the calendar months, but now these are question marks? I have no way of adding these back as that part of the widget is locked so I don’t understand what broke? :sob::tired_face:

Autosave doesn’t save resources so if you used a Komponent or a Bitmap and deleted those bitmaps than those won’t be recovered. Did you add a Komponent from an APK you then uninstalled? Or from external storage and then removed the file? If so please add it back and reload the autosave.

No, I did not delete anything. After changing the #x# grid on my home screen via Nova Launcher (see attached), my widget just disappeared. I have 3 widgets on 1 screen. Weather, calendar, and music. Only the calendar (the largest) was somehow “kicked off” the screen. Going back into KWGT, and trying to find my widget was confusing, as the thumbnail was also blank from the list of autosaves. Once I figured out what it was, and tried to load it, it was restored from a save point many days/weeks prior to what I had just been working on, and then some fonts and other “stock” elements of the original widget (aka the arrow options) just didn’t work, showed question marks, or reverted to some kind of default font. Like the name of the month had reverted to Roboto, and only when I went in to check/reselect the font it kinda popped back once I started scrolling through the font list, I hadn’t even selected the font and it changed back automatically. I think there’s just something that made it bug out by changing the grid while having widgets on the screen. I thought they would just resize automatically, or I’d just have to resize the boxes, but it blew up instead. :face_exhaling: