Lock status return 0 no matter what. and some shell command only update went phone has unlocked

hi. i just bought the pro key. and i thought it will fix it. whoever its not. and dont worry i not going to refund it. this app really great.

the real problem is.. on xperia xz1 android 9. JP rom i try to get phone lockscreen status. the easy way is using build in template to get lock screen status(system info >device lock) whoever i notices went testing it. it doesnt update. no matter what it always return 0. i try to re check if there permission missing. but none. soo i try alternative way using shell. it does work... the problem. it only sent/update that after unlock the phone. i know this since last screen i use it editor and i print the data and see. it does update for 1 second then back to original.

i tried may trick. some even doenst give any result like sysdump window or power.

in fact i try soo many that i forget what all command i tried. anyway the only working command(kinda) is using NFC check.(idk how or why but both on klck and adb it self it working fine) except that delay.

i do use xperia lockscreen(it not default android since it kinda different from default). the thing is. my whole phone theme is windows phone. and the last touch i need is windows halo(or just icon and text that change went phone unlocked) and yes, thanks to fingerprint and face unlock. my phone actually unlock the phone before lock screen even showing. the result is very seamless lockscreen between klck and my launcher without swiping again to unlock.

really need this to work thanks. and sorry for bad english