Launch app when touching Icon does Not work

Hi, I Installed the Pro Version of klwp on my Mi5 running Nova Launcher. Unfortunately no App opens when touching corresponding icons on the installed presets. I relinked everything anderen build my own lwp created a form and attached the launch app touch action. Just a Shirt vibration Feedback but no app opens. Can someone please help me? Thanks a lot

Ho Theo,

So please check the following:

  • Ensure you are running on latest KLWP release
  • The actions you are touching are mapped to something you have (i understand you already checked this), it can be easily verified by clicking the touch area in the editor preview and pressing "edit" when the popup comes up
  • Ensure that your launcher is correctly sending the touch to the live wallpaper, on some launcher like Lightning Launcher this needs to be enabled in the settings
  • Ensure that on touch you get a proper vibration and ensure that nothing is placed on top of the area, like the Launcher doc, some widget or some other component

Hey, thanks for your reply. I checked everything. I use Nova launcher and dont know where I can set up this correct sending of touch events.

Could this problem be connected to my rom (multi rom)? I cannot find anything in the web about my problem. Its only about launching apps. The other touchoptions are working properly.

No one reported issues with touch on Nova, so if you load a blank preset add a shape in the center add open an app to touch nothing happens? With ANY app? Are you sure you are on latest Nova and latest KLWP?

I have the same problem as well, it started a few days ago. I think an update got pushed (I lost root access and then suddenly discovered I had installed Nougat) via automatic updates and something got screwed up. There seems to be some interference between Nova Launcher and the stock Xiaomi MIUI8 launcher after the update. Cycling between Stock and Nova launcher doesn't work.

There's definitely the usual vibration, but no app will launch. however buttons for the RSS feed does work.

Mi5/nougat/nova launcher. Same problem. Is KGWT and Klwp have different algorithm for launch app? In klwp launching app/activity not working, but working in KGWT.

I can confirm that the ROM was causing the problems. I reverted back to the Mi5 Stable Global ROM V8.1.4.0.MAAMIDI (MIUI8) and the problem is fixed..

I got the same problem after upgrading to V8.2. Please look into this issue.

Damm m8 i just installed multirom :'(

You can try different way to do that just put that app shortcut on that and made it's logo transparent and use it as you like

Touch depends on the Launcher so if KLWP is not getting the touch most of the times is the Launcher not sending it. Please refer to this article for most common solutions:


Stil have the problem with launching Nova action -> drawer under MIUI 9 7.12.14 and KLWP Pro 3.29b733810.

Is there a way to access to nova drawer by another way than nova actions ?

Issue is fixed for all apps except Nova Action... Mr Frank Monza pl try to fix this problem.... I m using MIUI latest 9.2.1 Global Stable.

I know this is like a year old but he is running a ROM which is probably the issue as usually it always is when people are running a custom ROM and then wondering why something doesn't work LOL


Soory for my bad English.

I have the same issue, till yesterday i have no Problems, and today no App open, i can fell the vibration but nö App open.

I use:

Nova 6.2.3

KLWP 3.43

On Pocophone Miui Global 11.0.5

In Klwp Editor i verified by clicking on a touch area, an press edit, all touch actions wirke fine.

Same issue, same launcher and klwp 3.43, on mi mix miui eu 10.3.3

Hi! Same problem but I fixed it. Go to settings - permissions - other permissions - find kustom, klwp, kwgt etc and make sure START IN BACKGROUND is enabled.(also enable Home screen shortcutS). Cheers!

: tks for share, i fixed it

Hi Ardillasuicida,

thank you for share, i fixed it!

I am using kwgt pro widget with nova on funtouch os since past 2 days started facing issue that widget gets freezes and didn't responds at all... Already given all permissions to nova and kwgt and kwgt pro. When this freeze happened I have to go to app settings and force stop kwgt and after that only it starts responding for some time and again same issues starts