KLWP [BUG]: field using global text not updated

KLWP 3.36, Android 9

No komponent involved, all in root !

  1. Add a global, text type, named test containing this formula : $df(hh:mm)$
    $if(si(alarmon),"Alarm "+ tf(si(alarmd))+" (vol "+si(vola)+"%)")$
  2. Add text item.
  3. Use the test global in the text field.

Result : the time is not updated. If alarm is set or unset, the text item is not updated to reflect changes. The entire text item is frozen in time. This until the screen switch off/on.

But if you directly use the formula into the text field instead of a text global, all work, instant refresh.

Very frustrating if you plan to use globals to let users customize/translate the wallpaper.

Related reported issues :




Hi,your code it's working well in my phone with android 7, samsung s6, look if Klwp are not in Save Battery in your phone, maybe this is the problem. Otherwise I don't know if Klwp is updated to Android 9, I think that Frank Monza is in this at this moment.👍

Battery optimisation is not the problem. Formula are refreshed if they are used directly in an item field but not if item field use a global that contains formula. That’s my point. The steps are easy to reproduce. The formula I gave is just for example to make obvious the fact the item is frozen in one case and not in the other.

Hi Fre👍 , in my phone the two options are working well, in global and directly

If you want you can post this same problem in the G+ Kustom Official page, here you have more users and moderators, that maybe can help you best.

Maybe it’s a Pie issue then.

Yes but here is the place to report bug.

Probably is a Pie issue, in his Twitter Frank Monza said that he is working in the update to the Android 26,I think is the Pie version, but like I said you can make this question in G+, I see users reporting presets and other in Pie version, maybe they can make a test and report if your problem is the same in his phones. Good luck😃👍

Important detail and workaround.

If you enter $gv(test)$ into the text field instead of checking the box and assigning the test global, it works.

Ohh yes, I don't explain this, in this case, you need to put the global in the text field, it's the only way that it work.👍

Same here after updating to pie. Confirmed.

Fixed in 3.37