Issues with Bitmaps and Loading Themes

For a while now, I have been running into various issues with KLWP, mainly related to bitmaps and theme loading.

When I go to install the KLWP app and I go through the setup process, importing my wallpaper, it works perfectly fine for a short period of time. After applying, it looks normal. However, usually after a few minutes, the images start to load, and the button I have animated for a menu overlay starts to be very slow. The apps still work, but anything that requires the screen to update is very slow. All of the colors and everything are fine, but any images disappear completely.

Usually after a restart or if I have to remove the wallpaper and set it again, it will either load infinitely or it will give an error saying that it could not determine if the file was a child or the folder. It will then do this until a reinstall, and it happens with any wallpaper.

I have tried various different versions of the app. I used to use 3.55 when it broke, and now I am using the latest play store version which has not fixed the issues, although fonticons appear to no longer have any problems, they used to also break. I thought at first that it might be because I use a significant number of bitmaps and globals, as my wallpaper has 24 possible theme choices, each with 2 images and a color that change. However, I don’t think this is an unreasonable amount, and it doesn’t seem like it could be the only issue. I have even completely remade the wallpaper when I wanted to reformat everything, and that did not fix the issue.

I’m not sure what else to do at this point, so hopefully there is a solution to the issues I’ve been experiencing.

Try turning on the “Disable Parallel Rendering” option. Just go to KLWP’s app settings >> Advanced options.

also check your wallpaper resource (in .klwp file) has completely exported, cuz some time it won’t export external resource e.g. (bitmap, svg, ttf).
i was got this bug once, but i didn’t remember the version ish

I have tried that, it doesn’t change anything unfortunately

I have exported it like at least 10 times probably, and I have completely recreated it twice, so I imagine it must have exported properly at least once. Also, it is a large file size so I think it’s correct, as everything loads when I load it first, everything just disappears later.

Can you please update to 3.74 and check again? Ensure nothing clears Kustom cache. If you still have issues please send your preset at [email protected] will check it