[HELP] presets loading as a black screen

I went in to my wallpaper settings to adjust the colour of something, and now everything loads as a black screen. Everything is still there, when I touch where the komponents would be, they still work. I've tried restarting my phone, I've uninstalled and reinstalled the app, I've tried other presets; nothing works. I'm running Android 7.1.1 on Nexus 6P with Nova Launcher Prime (Also, whenever I restart my phone, I have to reset my wallpaper. That's been happening since I first installed KLWP)

So the reboot issue is probably due to the availability of the SD card, i am trying to reproduce that, but the other issue is not clear to me, so every preset loads as a black screen? Are you on a custom ROM?

I'm on the beta program (apparently the reboot issue happened with a few people -Reddit)

I'm not on custom ROM, I'm in the beta, but running stock, not rooted.

Whether I use my own custom preset or any of the included/purchased ones. They load as a black screen, but I can still interact with it (if I touch where my calendar is supposed to be, it still opens my calendar).

This is super strange, i have here in front of me the same device, same Android version and with Nova beta on it, its the main test device. Are any of the live wallpaper on the store working? For example, is Muzei working on your device?

I only got the app a few weeks ago, and everything was working fine until the other night. Every preset loads as a black screen.

When I change to a random normal wallpaper and then go to change it back, it takes a long time for it to even load the preset in my "choose wallpaper" screen.